using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\p{Lu})(\p{Lu}+)";
string substitution = @"$1\L$2";
string input = @"dsfjkljsdfjlsjdfABCDdfsfsdff
ABCD
sqdfsfffffABCD
ABCDEjkjdskfjdsklfj
fslffmldfmlABCDQkldkfdskfsdkfmlsk
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}