// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\p{Lu})(\p{Lu}+)").unwrap();
let string = "dsfjkljsdfjlsjdfABCDdfsfsdff
ABCD
sqdfsfffffABCD
ABCDEjkjdskfjdsklfj
fslffmldfmlABCDQkldkfdskfsdkfmlsk
";
let substitution = "$1\\L$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}