$re = '/(\p{Lu})(\p{Lu}+)/m';
$str = 'dsfjkljsdfjlsjdfABCDdfsfsdff
ABCD
sqdfsfffffABCD
ABCDEjkjdskfjdsklfj
fslffmldfmlABCDQkldkfdskfsdkfmlsk
';
$subst = "$1\L$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;