using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<open_dsq>(?<!\\)[""\'])(?P<dsq_value>(?s:\\.|(?!\\|(?P=open_dsq)).)*?)(?P<close_dsq>(?P=open_dsq))";
string input = @"$single_quoted = 'hello world';
$double_quote = ""hi there"";
$escaped_single_quote = 'it\'s tricky';
$escaped_double_quotes = ""\""it's\"" tricky"";
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}