const regex = /(?P<open_dsq>(?<!\\)["\'])(?P<dsq_value>(?s:\\.|(?!\\|(?P=open_dsq)).)*?)(?P<close_dsq>(?P=open_dsq))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<open_dsq>(?<!\\\\)["\\\'])(?P<dsq_value>(?s:\\\\.|(?!\\\\|(?P=open_dsq)).)*?)(?P<close_dsq>(?P=open_dsq))', 'g')
const str = `\$single_quoted = 'hello world';
\$double_quote = "hi there";
\$escaped_single_quote = 'it\\'s tricky';
\$escaped_double_quotes = "\\"it's\\" tricky";
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}