use strict;
my $str = '$single_quoted = \'hello world\';
$double_quote = "hi there";
$escaped_single_quote = \'it\\\'s tricky\';
$escaped_double_quotes = "\\"it\'s\\" tricky";
';
my $regex = qr/(?P<open_dsq>(?<!\\)["\'])(?P<dsq_value>(?s:\\.|(?!\\|(?P=open_dsq)).)*?)(?P<close_dsq>(?P=open_dsq))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}