import re
regex = re.compile(r"(?P<open_dsq>(?<!\\)[\"\'])(?P<dsq_value>(?s:\\.|(?!\\|(?P=open_dsq)).)*?)(?P<close_dsq>(?P=open_dsq))")
test_str = ("$single_quoted = 'hello world';\n"
"$double_quote = \"hi there\";\n"
"$escaped_single_quote = 'it\\'s tricky';\n"
"$escaped_double_quotes = \"\\\"it's\\\" tricky\";\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")