import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<open_dsq>(?<!\\\\)[\"\\'])(?P<dsq_value>(?s:\\\\.|(?!\\\\|(?P=open_dsq)).)*?)(?P<close_dsq>(?P=open_dsq))";
final String string = "$single_quoted = 'hello world';\n"
+ "$double_quote = \"hi there\";\n"
+ "$escaped_single_quote = 'it\\'s tricky';\n"
+ "$escaped_double_quotes = \"\\\"it's\\\" tricky\";\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}