#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*\[[\-\w]*\d\]"
Local $sString = "[ABC-123] Test message" & @CRLF & _
"[XYZ-312] Message test" & @CRLF & _
"[XYZ-ABCD-321] Awesome sauce" & @CRLF & _
"Test message" & @CRLF & _
"[ABC] Testing stuff" & @CRLF & _
"[Add ABC-123 files]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")