package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*\[[\-\w]*\d\]`)
var str = `[ABC-123] Test message
[XYZ-312] Message test
[XYZ-ABCD-321] Awesome sauce
Test message
[ABC] Testing stuff
[Add ABC-123 files]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}