import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\[[\\-\\w]*\\d\\]";
final String string = "[ABC-123] Test message\n"
+ "[XYZ-312] Message test\n"
+ "[XYZ-ABCD-321] Awesome sauce\n"
+ "Test message\n"
+ "[ABC] Testing stuff\n"
+ "[Add ABC-123 files]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}