re = /^\s*\[[\-\w]*\d\]/m
str = '[ABC-123] Test message
[XYZ-312] Message test
[XYZ-ABCD-321] Awesome sauce
Test message
[ABC] Testing stuff
[Add ABC-123 files]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end