$re = '/^\s*\[[\-\w]*\d\]/m';
$str = '[ABC-123] Test message
[XYZ-312] Message test
[XYZ-ABCD-321] Awesome sauce
Test message
[ABC] Testing stuff
[Add ABC-123 files]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);