const regex = /^\s*\[[\-\w]*\d\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*\\[[\\-\\w]*\\d\\]', 'gm')
const str = `[ABC-123] Test message
[XYZ-312] Message test
[XYZ-ABCD-321] Awesome sauce
Test message
[ABC] Testing stuff
[Add ABC-123 files]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}