using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":(ref|doc|term):`([^<`:]+):([^:]+)`";
string input = @"Here are some made up external :ref:`python:references` to the :doc:`python:index` docs and this is an :doc:`internal` reference that isn't converted.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}