package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):(ref|doc|term):`([^<`:]+):([^:]+)``)
var str = `Here are some made up external :ref:\`python:references\` to the :doc:\`python:index\` docs and this is an :doc:\`internal\` reference that isn't converted.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}