$re = '/:(ref|doc|term):`([^<`:]+):([^:]+)`/m';
$str = 'Here are some made up external :ref:`python:references` to the :doc:`python:index` docs and this is an :doc:`internal` reference that isn\'t converted.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);