const regex = /:(ref|doc|term):`([^<`:]+):([^:]+)`/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':(ref|doc|term):`([^<`:]+):([^:]+)`', 'gm')
const str = `Here are some made up external :ref:\`python:references\` to the :doc:\`python:index\` docs and this is an :doc:\`internal\` reference that isn't converted.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}