// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m):(ref|doc|term):`([^<`:]+):([^:]+)`").unwrap();
let string = "Here are some made up external :ref:`python:references` to the :doc:`python:index` docs and this is an :doc:`internal` reference that isn't converted.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}