import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+(?:-\\w+)+";
final String string = "some number L-BSC-MAP-01 - some other words\n"
+ "V-A - some other words\n"
+ "some number L-BFC-MAP-05 some other words - some other words\n"
+ "some number V-B some other words\n"
+ "some number L-BFC-MAD-04 some other words";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}