import re
regex = re.compile(r"\w+(?:-\w+)+", flags=re.MULTILINE)
test_str = ("some number L-BSC-MAP-01 - some other words\n"
"V-A - some other words\n"
"some number L-BFC-MAP-05 some other words - some other words\n"
"some number V-B some other words\n"
"some number L-BFC-MAD-04 some other words")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")