re = /\w+(?:-\w+)+/m
str = 'some number L-BSC-MAP-01 - some other words
V-A - some other words
some number L-BFC-MAP-05 some other words - some other words
some number V-B some other words
some number L-BFC-MAD-04 some other words'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end