const regex = /\w+(?:-\w+)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+(?:-\\w+)+', 'gm')
const str = `some number L-BSC-MAP-01 - some other words
V-A - some other words
some number L-BFC-MAP-05 some other words - some other words
some number V-B some other words
some number L-BFC-MAD-04 some other words`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}