# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\p{Letter}\p{Number}#]+//gmu;t' <<< "!#Ab+Z1_↕.🍏2ü翻訳"