use strict;
my $str = '!#Ab+Z1_↕.🍏2ü翻訳';
my $regex = qr/[^\p{Letter}\p{Number}#]+/mup;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";