package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\p{Letter}\p{Number}#]+`)
var str = `!#Ab+Z1_↕.🍏2ü翻訳`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}