// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)[^\p{Letter}\p{Number}#]+").unwrap();
let string = "!#Ab+Z1_↕.🍏2ü翻訳";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}