$re = '/[^\p{Letter}\p{Number}#]+/mu';
$str = '!#Ab+Z1_↕.🍏2ü翻訳';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;