const regex = /[^\p{Letter}\p{Number}#]+/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\p{Letter}\\p{Number}#]+', 'gmu')
const str = `!#Ab+Z1_↕.🍏2ü翻訳`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);