import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.{10,})(?=.*[A-Z].*)(?=.*[a-z].*)(?=.*\\d.*)(?=.*[\\!\\@\\#\\$\\%\\^\\&\\*].*)(?=^[\\!\\@\\#\\$\\%\\^\\&\\*a-zA-Z0-9]+$)^.*$";
final String string = "n0capitals!\n"
+ "NoNumbers!\n"
+ "NOL0WERCASE!\n"
+ "N0symbolss\n"
+ "TooS#0rt!\n"
+ "B4dcharac+er!\n\n"
+ "Passw0rd1!\n\n"
+ "longerPassw0rd2!\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}