$re = '/(?=.{10,})(?=.*[A-Z].*)(?=.*[a-z].*)(?=.*\d.*)(?=.*[\!\@\#\$\%\^\&\*].*)(?=^[\!\@\#\$\%\^\&\*a-zA-Z0-9]+$)^.*$/m';
$str = 'n0capitals!
NoNumbers!
NOL0WERCASE!
N0symbolss
TooS#0rt!
B4dcharac+er!
Passw0rd1!
longerPassw0rd2!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);