import re
regex = re.compile(r"(?=.{10,})(?=.*[A-Z].*)(?=.*[a-z].*)(?=.*\d.*)(?=.*[\!\@\#\$\%\^\&\*].*)(?=^[\!\@\#\$\%\^\&\*a-zA-Z0-9]+$)^.*$", flags=re.MULTILINE)
test_str = ("n0capitals!\n"
"NoNumbers!\n"
"NOL0WERCASE!\n"
"N0symbolss\n"
"TooS#0rt!\n"
"B4dcharac+er!\n\n"
"Passw0rd1!\n\n"
"longerPassw0rd2!\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")