re = /(?=.{10,})(?=.*[A-Z].*)(?=.*[a-z].*)(?=.*\d.*)(?=.*[\!\@\#\$\%\^\&\*].*)(?=^[\!\@\#\$\%\^\&\*a-zA-Z0-9]+$)^.*$/m
str = 'n0capitals!
NoNumbers!
NOL0WERCASE!
N0symbolss
TooS#0rt!
B4dcharac+er!
Passw0rd1!
longerPassw0rd2!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end