const regex = /(?=.{10,})(?=.*[A-Z].*)(?=.*[a-z].*)(?=.*\d.*)(?=.*[\!\@\#\$\%\^\&\*].*)(?=^[\!\@\#\$\%\^\&\*a-zA-Z0-9]+$)^.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.{10,})(?=.*[A-Z].*)(?=.*[a-z].*)(?=.*\\d.*)(?=.*[\\!\\@\\#\\$\\%\\^\\&\\*].*)(?=^[\\!\\@\\#\\$\\%\\^\\&\\*a-zA-Z0-9]+$)^.*$', 'gm')
const str = `n0capitals!
NoNumbers!
NOL0WERCASE!
N0symbolss
TooS#0rt!
B4dcharac+er!
Passw0rd1!
longerPassw0rd2!
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}