#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"id":(\d+),.*"
Local $sString = "{"data":[{"id":1,"description":"Test description 1", "Location": "test location 1"}, {"id":2,"description":"Test description 2", "Location": "test location 2"}, {"id":3,"description":"Test description 3", "Location": "test location 3"}]}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")