re = /"id":(\d+),.*/m
str = '{"data":[{"id":1,"description":"Test description 1", "Location": "test location 1"}, {"id":2,"description":"Test description 2", "Location": "test location 2"}, {"id":3,"description":"Test description 3", "Location": "test location 3"}]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end