import re
regex = re.compile(r"\"id\":(\d+),.*", flags=re.MULTILINE)
test_str = "{\"data\":[{\"id\":1,\"description\":\"Test description 1\", \"Location\": \"test location 1\"}, {\"id\":2,\"description\":\"Test description 2\", \"Location\": \"test location 2\"}, {\"id\":3,\"description\":\"Test description 3\", \"Location\": \"test location 3\"}]}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")