import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"id\":(\\d+),.*";
final String string = "{\"data\":[{\"id\":1,\"description\":\"Test description 1\", \"Location\": \"test location 1\"}, {\"id\":2,\"description\":\"Test description 2\", \"Location\": \"test location 2\"}, {\"id\":3,\"description\":\"Test description 3\", \"Location\": \"test location 3\"}]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}