using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""id"":(\d+),.*";
string input = @"{""data"":[{""id"":1,""description"":""Test description 1"", ""Location"": ""test location 1""}, {""id"":2,""description"":""Test description 2"", ""Location"": ""test location 2""}, {""id"":3,""description"":""Test description 3"", ""Location"": ""test location 3""}]}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}