import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">((\\s|[a-zA-Z]|[0-9]|-|_|\\+)+\\s)<";
final String string = "<li class=\"list-item p-a-0 content-rating\">\n\n"
+ "<b class=\"inline\">Rating:</b>\n\n"
+ " 13+ - Teens 13 or older\n\n"
+ "</li>\n"
+ "<li class=\"list-item p-a-0\">\n"
+ "<b class=\"inline\">Country:</b>\n\n"
+ " China\n\n"
+ "</li>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}