import Foundation
let pattern = #">((\s|[a-zA-Z]|[0-9]|-|_|\+)+\s)<"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<li class="list-item p-a-0 content-rating">
<b class="inline">Rating:</b>
13+ - Teens 13 or older
</li>
<li class="list-item p-a-0">
<b class="inline">Country:</b>
China
</li>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)