import re
regex = re.compile(r">((\s|[a-zA-Z]|[0-9]|-|_|\+)+\s)<", flags=re.MULTILINE)
test_str = ("<li class=\"list-item p-a-0 content-rating\">\n\n"
"<b class=\"inline\">Rating:</b>\n\n"
" 13+ - Teens 13 or older\n\n"
"</li>\n"
"<li class=\"list-item p-a-0\">\n"
"<b class=\"inline\">Country:</b>\n\n"
" China\n\n"
"</li>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")