// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)>((\s|[a-zA-Z]|[0-9]|-|_|\+)+\s)<").unwrap();
let string = "<li class=\"list-item p-a-0 content-rating\">
<b class=\"inline\">Rating:</b>
13+ - Teens 13 or older
</li>
<li class=\"list-item p-a-0\">
<b class=\"inline\">Country:</b>
China
</li>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}