using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(?s)<body>\K\s*<tag(?:(?!<inner_block=25>).)+</tag>";
        string substitution = @"";
        string input = @"<body>
<tag>
<number=1>
<inner_block=5>
</tag>
<tag>
<number=12>
<inner_block=15>
</tag>
<tag>
<number=21>
<inner_block=25>
</tag>
<tag>
<number=29>
<inner_block=35>
</tag>
</body>";
        
        Regex regex = new Regex(pattern);
        string result = regex.Replace(input, substitution, 1);
    }
}