$re = '~(?s)<body>\K\s*<tag(?:(?!<inner_block=25>).)+</tag>~';
$str = '<body>
<tag>
<number=1>
<inner_block=5>
</tag>
<tag>
<number=12>
<inner_block=15>
</tag>
<tag>
<number=21>
<inner_block=25>
</tag>
<tag>
<number=29>
<inner_block=35>
</tag>
</body>';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;