import Foundation
let pattern = #"(?s)<body>\K\s*<tag(?:(?!<inner_block=25>).)+</tag>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<body>
<tag>
<number=1>
<inner_block=5>
</tag>
<tag>
<number=12>
<inner_block=15>
</tag>
<tag>
<number=21>
<inner_block=25>
</tag>
<tag>
<number=29>
<inner_block=35>
</tag>
</body>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}