const regex = new RegExp('(?s)<body>\\K\\s*<tag(?:(?!<inner_block=25>).)+</tag>', '')
const str = `<body>
<tag>
<number=1>
<inner_block=5>
</tag>
<tag>
<number=12>
<inner_block=15>
</tag>
<tag>
<number=21>
<inner_block=25>
</tag>
<tag>
<number=29>
<inner_block=35>
</tag>
</body>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);