use strict;
my $str = '<body>
<tag>
<number=1>
<inner_block=5>
</tag>
<tag>
<number=12>
<inner_block=15>
</tag>
<tag>
<number=21>
<inner_block=25>
</tag>
<tag>
<number=29>
<inner_block=35>
</tag>
</body>';
my $regex = qr~(?s)<body>\K\s*<tag(?:(?!<inner_block=25>).)+</tag>~p;
my $subst = '';
my $result = $str =~ s~$regex~$subst~r;
print "The result of the substitution is' $result\n";