import re
regex = re.compile(r"(?s)<body>\K\s*<tag(?:(?!<inner_block=25>).)+</tag>")
test_str = ("<body>\n"
"<tag>\n"
"<number=1>\n"
"<inner_block=5>\n"
"</tag>\n"
"<tag>\n"
"<number=12>\n"
"<inner_block=15>\n"
"</tag>\n"
"<tag>\n"
"<number=21>\n"
"<inner_block=25>\n"
"</tag>\n"
"<tag>\n"
"<number=29>\n"
"<inner_block=35>\n"
"</tag>\n"
"</body>")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)