#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{2}[A-Z]-[A-Z]+$"
Local $sString = "PASS :" & @CRLF & _
"16B-SCHUIF" & @CRLF & _
"32B-MATH" & @CRLF & _
"08B-SCHUIF" & @CRLF & _
"" & @CRLF & _
"FAIL :" & @CRLF & _
"8B-SCHUIF" & @CRLF & _
"16B-42SCHUIF" & @CRLF & _
"16BSCHUIF" & @CRLF & _
"16-SCHUIF" & @CRLF & _
"16B-SCHUIF42A"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")